Grow your CSS skills. Land your dream job.

I love IE 7 (sarcasm) ! … Interesting bug to solve !

  • # September 16, 2012 at 7:23 am

    Hi,

    all works fine, in all borwsers, even IE 9 + 8.

    Well … IE 7 … is a problem.

    Instead of a mile long text here I showcase it in live video in just 3 mins.

    No fear, good audio quality + HD video.

    http://dl.dropbox.com/u/19975953/css-tricks/I-E-7.mp4

    Please advise me if possible.

    http://weby.krsiak.cz/klient/chrlicky-chov/

    http://weby.krsiak.cz/klient/chrlicky-chov/style.1.0.4.css

    P.S.:

    I know, the .css amd .html looks weird and a bit of mess.

    I am just trying to put it together, up and running.

    It is ThemeForest theme, not my code.

    # September 16, 2012 at 8:08 am

    I am not sure what the heck is going on there…but, i suppose if you don;t mind just hacking at it (like most fixes for IE) …just add an id/class to the ‘conatainer_12′ that holds your columns and apply negative position styles for IE…I don’t mess with anything < IE8 anymore so maybe someone who still does can come along and help out a little better…Good luck.

    # September 16, 2012 at 8:12 am

    @kgscott284

    hi, thanks for look at it :)

    I did that, I tried “move it up” by negative 400px
    but the “hover over + jump my content away” effect still was there

    # September 16, 2012 at 8:19 am

    dang…what a pain in the booty…I have no way to debug it really else I would be working on it for you…again, good luck!

    # September 16, 2012 at 9:06 am

    I only had a quick glance to your problem, but how did you set this up ? I mean : floats or inline-blocks ?

    # September 16, 2012 at 9:34 am

    .row {overflow: hidden;}

    # September 16, 2012 at 11:20 am

    @HugoGiraudel – I got this ThemeForest theme, so I basically setup nothing

    all the client wanted was to insert the content and delete/add stuff from time to time

    the CSS itself is really crazy

    I will try what @wolfcry911 suggests

    # September 16, 2012 at 1:24 pm

    You may want to try this :

    .row {
    *zoom: 1;
    }
    # September 17, 2012 at 12:54 pm

    thanks guys
    none of this helped :)

    I managed to beat that with this



    /* == FIX INDEX == */
    #index .text-block-1 {
    width: 190px;
    float: left;
    margin-right: 10px;
    }

    I basically deleted all that the ThemeForest CSS was taking care of and rewrote it from scratch

    well at least, this last bug convinced me no longer use ThemeForest themes

    as I was disliking it recently more and more anyway

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.

*May or may not contain any actual "CSS" or "Tricks".