Grow your CSS skills. Land your dream job.

help with wrappers setting own width?

  • # April 11, 2013 at 9:19 pm

    can someone take a look at http://www.worldtraveler.com the content_wrapper is like 1663×2440 and page wrapper are all messed up. I know there are a lot of things goin wrong here but would like to center all the content on the page

    # April 12, 2013 at 4:24 am

    There is no width set on #content-wrapper…so that might solve some problems.

    I’m not sure why (Oh why) the #content-area is built with a a table but that will cause some issues too.

    Without getting into it too much you seem to have divs assigned widths that do not relate to the #container width.

    # April 12, 2013 at 11:03 am

    I added a width to 980 but its still 2461 and the bottom scroll pops up seems like there is a lot of useless white space on the right side

    # April 12, 2013 at 11:16 am

    I have no idea where 2461 came from. i can see that it’s clearly 980px now.

    As I mentioned, I suspect that the issue is that you have a layout using tables…they always mess things up.

    # April 12, 2013 at 11:25 am

    The issue is with the div with id of `blast` so `

    ` when I deleted this node from the dom it fixed the width issue.
    # April 12, 2013 at 11:32 am

    Actually, I don’t think it will.

    Look with Web inspector and select the div#content-wrapper…it clearly has elements that are overflowing.

    I maintain it’s the table. :)

    # April 12, 2013 at 11:42 am

    This is what I see in the Google inspector.

    # April 12, 2013 at 11:57 am

    Yeah…but that’s still in the container (which, oddly, does not contain the whole page)…

    no…this is what I am talking about.

    # April 12, 2013 at 12:09 pm

    I think there are multiple issues here. The `#blast` div is causing the horizontal scrollbar. I’m guessing the `#content_wrapper` and `#content` have some margin/float issues.

    # April 12, 2013 at 12:16 pm

    There’s also multiple syntax errors that might be causing issues. `` is being closed twice, line 81 & 108. Validator says “document type does not allow element ‘body’ here” for the `body` element, which could be causing all kinds of issues.

    # April 12, 2013 at 12:18 pm

    The HTML structure is pretty bad TBH.

    That #blast is absolutely positioned which (I will always maintain) is the last option one should use.

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.

*May or may not contain any actual "CSS" or "Tricks".