Grow your CSS skills. Land your dream job.

Help me find the problem

  • # January 2, 2009 at 4:32 pm

    seems the further I go the more problems I find. Once I learn from them Im set though!

    here is the URL

    http://www.linkcreativedesign.com

    I have three problems now and Im totally stuck as to what is happening.

    problem one: when i click on the title of my blog entries, it says Error 404, and does not display it in single page mode.

    problem two: I want to get my search bar to go up into the black strip and to the right. I floated it to the right but its too far down.

    problem three: I cannot find where to take away the black background from my post entry title, and what that little artifact is within the title that is right under the text.. it almost looks the top part of more text.

    any help would be appreciated. Thanks in advance

    Rob
    # January 2, 2009 at 5:49 pm
    "LinCSS25" wrote:
    problem one: when i click on the title of my blog entries, it says Error 404, and does not display it in single page mode.

    problem two: I want to get my search bar to go up into the black strip and to the right. I floated it to the right but its too far down.

    problem three: I cannot find where to take away the black background from my post entry title, and what that little artifact is within the title that is right under the text.. it almost looks the top part of more text.

    any help would be appreciated. Thanks in advance

    Problem one is a permalink problem. /%postname%/ sometimes does not work unless you edit the .htaccess file manually – OR – sometimes its a setting within your servers PHP settings…

    Problem two add "top:-40px;" to your CSS for #searchform look at the change it made and tell us if thats what you mean :)

    Problem three
    its inheriting the properties from your nav bar, thats why its got what seems to be black background – the H2 has a background of #000000 and the A (link text) has the image background. You have your #blog ID being used twice. Once for the actual blog posts, and once for the blog button in the nav bar :)

    # January 3, 2009 at 1:05 am

    Thanks!

    I found problem 3 myself before I saw your post.. Im so proud of me!

    your post for problem 2 worked like a charm.. thanks for that..

    One I am still trying to figure out. I had already had to do something with the .htaccess file so I could make the permalinks the %pagename%. WP had me ad some code into it… Ill have to tinker around with what you said.. and see if anyone else knows whats going on there.

    # January 3, 2009 at 5:55 am
    "LinCSS25" wrote:
    Thanks!

    I found problem 3 myself before I saw your post.. Im so proud of me!

    your post for problem 2 worked like a charm.. thanks for that..

    One I am still trying to figure out. I had already had to do something with the .htaccess file so I could make the permalinks the %pagename%. WP had me ad some code into it… Ill have to tinker around with what you said.. and see if anyone else knows whats going on there.

    well done, I think I can see your problem, your making posts in that page so your permalink should be set to %postname%.

    I know you are trying to make pages as well, but sometimes wordpress is fiddly like that.

    you may have to uninstall wordpress from the server, and start afresh, but before you make any posts/pages, make sure your settings are how you want them before writing any content with wordpress, thats what I had to do. I had to uninstall 4 times before it worked the way I wanted it to.

    Rob
    # January 3, 2009 at 6:19 am

    good advice ikthius – I still havnt got the permalinks I actually want working, im gonna try what you said too and see if I can get it going on mine. Thx for the tip :D

    # January 3, 2009 at 8:37 am
    "Robskiwarrior" wrote:
    good advice ikthius – I still havnt got the permalinks I actually want working, im gonna try what you said too and see if I can get it going on mine. Thx for the tip :D

    the only problem with all that is, your database ends up giving new posts a different number, so it wont look like post 1 post 2 etc… you could delete the database entries or the database itself, if your space allows.

    ik

    # January 3, 2009 at 1:38 pm

    Oh gosh Im afraid to do that.. but everything I have designed is saved in my template right so.. all that is safe.

    So I just unintall/delete everything WP on my hosting and put it back in with my template?

    im afraid Ill get all messed up with figuring out what needs reset on the data base.. I believe I have the ability to delete it and make a new one. If you have your permalinks set to %postname% what does the numbering matter? or are you talking about something else.

    # January 3, 2009 at 11:16 pm

    Did you try it ye Robskiwarrior? I am trying to avoid doing it ha. Let me know how it works for you if you decided to do it.

    Rob
    # January 4, 2009 at 6:05 am
    "LinCSS25" wrote:
    Did you try it ye Robskiwarrior? I am trying to avoid doing it ha. Let me know how it works for you if you decided to do it.

    lol no – I havnt had time yet :D

    I have a way of making a permalink kinda thing work better though – and thats with using the structure…

    /index.php/%postname%/

    If you dont mind the index.php lol that works for me for now, without making huge database changes…

    # January 4, 2009 at 7:44 pm

    so Im not sure how much of a tip this is but I fixed it seemly by simply messing around changing the permalink setting in WP. I changed it to a few different things and when I put it back to %postname% everything worked. Since someone said that it is kind of a quirky thing in WP I guess a quirky fix will fix it.. ha.

    I hope it stays that way, I just dont want to reinstall WP. lazy I guess ha.

    Rob
    # January 5, 2009 at 6:28 am
    "LinCSS25" wrote:
    so Im not sure how much of a tip this is but I fixed it seemly by simply messing around changing the permalink setting in WP. I changed it to a few different things and when I put it back to %postname% everything worked. Since someone said that it is kind of a quirky thing in WP I guess a quirky fix will fix it.. ha.

    I hope it stays that way, I just dont want to reinstall WP. lazy I guess ha.

    So basically you kicked it…

    Excelent work! :D

    # January 5, 2009 at 12:05 pm

    Lin,

    as long as you save your theme, and wordpress files everything is ok.

    the only thing you might have to do with a fresh database install is include the new database name, password and the likes to the install.php (you know that one wordpress asks you to add in the info to establish connection)

    thats it, your theme is just a collection of files that are not on the database, and your css files are in the same directory as the theme.

    as long as you back up what you want to back up, I leave a copy of wordpress locally on my machine, uninstall on the internet server, then re-upload the wordpress files, your site will still work the same way.

    but this time you can set your settings correctly before any posts are done, and you can test.

    remember I deleted about 4 databases, and installed and un-installed wordpress as many times also, before I was happy with how it worked

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.

*May or may not contain any actual "CSS" or "Tricks".