Grow your CSS skills. Land your dream job.

Full page background in wordpress

  • # June 25, 2013 at 11:45 am

    > thanks for the help, but overriding it in the css won’t work.. i’ve tried so many times by now. What do you think about setting the custom background to an empty-transparent png image?

    Please try it again, and show us. It should be easy so perhaps we can see where it goes wrong. You may have had some specificity issues, so adding “html” in front of it, or @Paulie_D‘s suggestion to use !important might help.

    Setting the background to a transparent image won’t work, because the background color will still be there (like I said, I’m not sure how to completely remove the color from the settings, only how to change it).

    # June 25, 2013 at 11:54 am

    It worked with the new code you posted paulie! THAAAANKYOUUU!

    finally!

    whats the difference between the code with the !important; /* or none */ and the other?

    # June 25, 2013 at 11:57 am

    The `/* xxxx*/` was just to indicate a comment.

    I think you can ‘reset’ the background by setting it to none but if `transparent` works then that’s OK.

    The `!important` addition just means, in CSS parlance, “I don’t care about whatever specificity rules might apply..USE THIS”.

    It should be used sparingly…very sparingly.

    # June 25, 2013 at 12:00 pm

    (Too bad !important is being chosen over specificity, but ah…..)

Viewing 4 posts - 16 through 19 (of 19 total)

You must be logged in to reply to this topic.

*May or may not contain any actual "CSS" or "Tricks".