Grow your CSS skills. Land your dream job.

CSS-Tricks Bug

  • # May 7, 2013 at 10:02 am

    I had the same issue with my blog, and my custom fonts weren’t showing. The cause was that my WordPress install was not located in the root folder of my site, and the fact that there was a difference between the WordPress Address (URL) and the Site Address (URL) in the general settings. I fixed it by using the full path to the custom font files, including the http and domain and all that.

    Not sure if that’s also what’s happening here of course (though I do believe Chris is also a supporter of not having the WordPress in the root).

    # May 7, 2013 at 10:38 am

    I’m on the case! It’s pretty complicated actually, because of some new nginx caching going on on the site, amongst other things. They SHOULD work from the CDN, but either Firefox started not allowing cross-origin fonts depite the headers, or my headers are wrong. And my headers SEEM to be right, but it’s hard to know because of the nginx stuff. I would just yank them off the CDN, but even that seems to be problematic in W3 Total Cache (not respecting my rejected files list). And I don’t want to turn off the CDN completely because that would be an even worse problem =).

    Anyway, quite the cat and mouse chase here. Thanks for all the information. I’ll get it sorted out soon.

    # May 7, 2013 at 12:06 pm

    Is there a difference between the forums and the rest of the page?

    Because I can see the icons in FF21 on http and https in the forums but nowhere else.

    # May 7, 2013 at 12:13 pm

    @dgriesel I think that there may be some difference because when I copy the inner HTML of the <head> tag on the Forums page and replace the inner HTML of the <head> tag on the Home page with the copied one the fonts seem to be working fine.

    # May 7, 2013 at 12:42 pm

    Yah there is a difference. The WordPress side uses the CDN and the forums do not, which is the crux of the issue.

    # May 7, 2013 at 12:57 pm

    This should be fixed in kind of a temporary way. The CSS and fonts just aren’t using the CDN now. Not ideal, but better than broken fonts.

    # May 7, 2013 at 7:32 pm

    I’ve seen this bug a few months ago.
    But it quickly went away, but it may have been that I had scripts disabled.

    Edit: Yes it was when I just had scripts disabled.

    ![Alt text](http://www.fragageddon.com/images/css-tricks1.jpg)

Viewing 7 posts - 16 through 22 (of 22 total)

You must be logged in to reply to this topic.

*May or may not contain any actual "CSS" or "Tricks".